라즈베리파이3 multi-camera Board V2 오류 질문합니다.



  • 안녕하세요.
    라즈베리파이3 Multi-Camera Board V2 를 사용하고 있고 카메라 4개를 이용하려는데 오류가 떠서 질문합니다.
    키보드, 마우스, HDMI, 5V 4A 전원을 연결하여사용하고 있으며,

    Multi-Camera Board V2 에 카메라 4개를 연결 후 사용을하면

    mmal: Cannot read camera info, keeping the defaults for OV5647
    mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
    mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
    mmal: Failed to create camera component
    mmal: main: Failed to create camera component
    mmal: Camera is not detected. Please check carefully the camera module is installed correctly
    

    라는 오류가 뜨고

    Multi-Camera Board V2 에 카메라 3개를 연결 후 사용을하면
    사진 3개가 찍힌후 저장되고 오류

    mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board
    

    가 뜨고

    각각 4개의 카메라를 라즈베리파이3에 하나씩 직접 연결하여 사진을 찍었을때는 문제가 없었고,
    1개를 연결할때, multi-camera Board V2를 이용하여 3개를 연결할때 카메라에 led는 모두 들어와있었습니다.

    하지만 4개를 연결하면 오류만 뜨고 아무 반응이 없었습니다.

    아무리 인터넷을 찾아봐도 해결이 안되 질문합니다…

    http://blog.naver.com/roboholic84/220818784395 코드 참고한 곳 입니다.


  • Global Moderator

    @giraffe 안녕하세요.
    산딸기마을 이장 나무꾼 입니다.

    우선 질문자 님의 상황을 정리 해 보면,

    [상황정리]

    목표 : Multi-Camera Board V2 정상 구동

    현재상황

    • 이용 중인 주변기기
      • 5V 4A 전원 어답터
      • HDMI 모니터
      • 키보드마우스 USB 포트 사용 중
      • Multi-Camera Board V2
    • mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board 에러메세지 출력

    • Pi-CAM 을 라즈베리파이 3B에 개별(1:1) 연결 시, 정상 구동 점검 시 이상없음 확인

    우선, 위 상황을 하나씩 따로 따로 분리해 보면 이미 알고 계시겠지만, 출력되는 mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board 의 메세지는 플랫 리본 케이블 의 이상데이터 검출을 의미합니다.

    이런 경우 두가지 상황에서 벌어지는데,

    • 첫번째는 소프트웨어적인 문제의 경우, 단순히 오래된 라즈비안 펌웨어의 업데이트만으로 대부분이 해결이 됩니다.

    • 두번째는 물리적으로 정말로 FLAT Ribbon Cable 손상이 되었을 경우 와 전원공급 불안정 문제

    입니다.

    하지만, 질문자님의 경우에 기술 해 주신 상황 조건 속에 개별 연결 시 문제가 없기에 궁극적으로는 사용 중이신

    • Multi-Camera Board V2 초기 제품불량

    으로 의심을 해 볼 수가 있을 듯 합니다.

    [함께 고민 해 볼 사항]

    • 라즈베리파이에 Multi-Camera Board V2 를 연결 후, 포트별 Pi-CAM 연결 시의 결과.

    우선은 위의 조건을 테스트 후, 결과를 알려 주셨으면 합니다.

    마지막으로 5V 4A* 전원을 이용 중이라고 하시었는데요.
    어떤 형태로 어떻게 전원을 공급 중인지도 알았으면 합니다.

    전원 공급방식에 따라 차이가 있기 때문 입니다.

    그럼 수고하세요.


답글을 작성하기 위해 로그인
 

Rasplay Forum 사이트로의 연결이 끊어졌습니다. 다시 연결을 시도하는동안 잠시만 기다려 주십시오.