[사용법] Runeaudio에서 삼바(SMB) 설정(리눅스-윈도우 폴더 연동)



  • Runeaudio 삼바(SMB) 설정(리눅스-윈도우 폴더 연동하기)
    How to setup ‘SMB’ share in Runeaudio

    Runeaudio에서 삼바를 설정하고 파일을 공유하면 윈도우에서 폴더나 파일을 볼 수 있습니다. 룬오디오에서 삼바(smb)를 설정하는 방법은 다음과 같습니다.

    putty와 같은 터미널을 이용해서 아래 명령어를 실행하세요.
    ID: root
    pw: rune

    # nano /etc/samba/smb.conf

    화면은 아래와 같습니다.

    #======================= Global Settings =======================
    
    [global]
    
    workgroup = **WORKGROUP**   <== 여기를 윈도우 워크그룹과 동일하게   설정
    server string = RuneAudio Player
    ……
    
    #======================= Share Definitions =======================
    
      directory mask = 0775
      create mask = 0775
    
    [music_store]
      comment = Music Datastore root (/mnt/MPD)
      path = /mnt/MPD/
      read only = no
      public = yes
      follow symlinks = yes
      wide links = yes
      ##아래 두 줄을 추가 add to below
      writeable = yes
      broweable = yes
    

    Ctrl + o 저장하고, Ctrl + x 에디터를 종료합니다.

    # reboot
    재부팅

    마지막으로 윈도우즈 탐색기를 열고 네트워크를 클릭하시면 ‘RUNEAUDIO’ 라는 이름이 보입니다. 끝.

    0_1461201376102_SMB02.png


  • Global Moderator

    @zzeromin 오 ~~~ 마크다운 잘쓰는데 ^^



  • 감사합니다^^; 이 부분이 항상 궁금했었는데 해결 되었습니다.



  • 라즈베리파이1, 1 B+에선 /etc/samba/smb.conf에서 WORKGROUP으로 수정해도 안될때가 있네요 검색해서 알게됐는데 이 이후에 SSH에서
    systemctl start smbd nmbd
    systemctl enable smbd nmbd
    를 쳐주면 네트워크환경에 바로 RUNEAUDIO가 생기네요^^;


  • Global Moderator

    @SOONJAZZ님이 [사용법] Runeaudio에서 삼바(SMB) 설정(리눅스-윈도우 폴더 연동)에서 한 말:

    즈베리파이1, 1 B+에선 /etc/samba/smb.conf에서 WORKGROUP으로 수정해도 안될때가 있네요 검색해서 알게됐는데 이 이후에 SSH에서
    systemctl start smbd nmbd
    systemctl enable smbd nmbd
    를 쳐주면 네트워크환경에 바로 RUNEAUDIO가 생기네요^^;

    테스트 결과를 공유해 주셔서 감사합니다.
    Samba 서비스가 비활성화 되어 있나 보군요.
    저도 처음 알았습니다.


답변을 위해 로그인하기