gstreamer1.0을 install하는 과정에서 자꾸 오류가 납니다. 도와주세요!



  • 안녕하세요 저는 이번에 라즈베리파이를 가지고 영상 스트리밍을 하기위해 gstreamer1.0을 install하였습니다. 그런데 install하는 과정에서 자꾸 에러가 떠서 install이 되지 않습니다. 패키지가 깨졌다는 뜻인 것 같은데 어떻게 해결해야 할지 전혀 모르겠습니다. 도와주십시오.
    빠른 답변 부탁드립니다.

    pi@raspberrypi:~ $ sudo apt-get install gstreamer1.0

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'gstreamer1.0-fluendo-mp3' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-vaapi' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-audiosource' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-vaapi-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-clutter' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-alsa' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-videosink' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-visualization' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-omx' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-base-apps' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-tools' for regex 'gstreamer1.0'
    Note, selecting 'libgstreamer1.0-0-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-pulseaudio' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-omx-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-ugly-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-base-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-really-bad' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-ugly' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-libav-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-good' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-ffmpeg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-good-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-bad-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-gnonlin-dbg' for regex 'gstreamer1.0'
    Note, selecting 'libgstreamer1.0-dev' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-audiosink' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-videosource' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-gnonlin' for regex 'gstreamer1.0'
    Note, selecting 'libgstreamer1.0-0' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-good-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-bad-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-gnonlin-doc' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-base' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-packagekit' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-nice' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-lame' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-x' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-libav' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-ugly-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-gnomevfs' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-base-dbg' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-bad' for regex 'gstreamer1.0'
    Note, selecting 'gstreamer1.0-plugins-good' instead of 'gstreamer1.0-visualization'
    gstreamer1.0-alsa is already the newest version.
    gstreamer1.0-libav is already the newest version.
    gstreamer1.0-plugins-base is already the newest version.
    gstreamer1.0-plugins-good is already the newest version.
    gstreamer1.0-x is already the newest version.
    libgstreamer1.0-0 is already the newest version.
    libgstreamer1.0-0 set to manually installed.
    gstreamer1.0-omx is already the newest version.
    gstreamer1.0-plugins-bad is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     gstreamer1.0-omx-dbg : Depends: gstreamer1.0-omx (= 1.0.0.1-0+rpi18rpi1g) but 1.2.0-1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

  • Global Moderator

    @KwonJin 안녕하세요 나무꾼 입니다.

    우선 라즈베리파이의 경우에는 현재 사용하는 운영체가 두가로 나뉘어 집니다.

    Debian 7.0 Wheezy versionDebian 8.0 Jessie version 입니다.

    사용하시는 운영체제가 정확히 어떻게 되시는 지요 ?

    또는 다운로드 받아서 설치한 이미지 날짜를 알려주셔야만 정확한 테스트도 가능하지 싶습니다.

    또한, 아무래도 요즘은 대부분이 Jessie version 유저분들일꺼라 추측이 되어지고,

    • 아래는 Debian 7.0 Wheezy version 인데, 정상적으로 설치가 가능 한 것으로 보여집니다.

    0_1465276189557_gstream1.0.jpg


답글을 작성하기 위해 로그인
 

Rasplay Forum 사이트로의 연결이 끊어졌습니다. 다시 연결을 시도하는동안 잠시만 기다려 주십시오.