[질문] RPI3 와 iptime 공유기의 연결이슈?



  • 안녕하세요, RPI3 입문1달 입니다.

    증상:

    1. RPI3 에서 iptime 공유기로 접속시도하면 접속이 안됩니다. 해당공유기는 핸드폰,노트북접속해서 사용중입니다.
    2. RPI3에서 핸드폰 테더링으로 접속 잘됩니다.

    설치내용:

    1. noobs 1.9.1로 rasbian 설치 및 update, upgrade 적용
      -> inux raspberrypi 4.4.11-v7+ #888 SMP Mon May 23 20:10:33 BST 2016 armv7l GNU/Linux
    2. country code를 GB,US,KR,JP 로 변경하며 테스트, KR은 안되고 GB,US,JP 에서 ssid scan은 되나 접속안됨

    wpa_cli로 연결시도시 메세지(연결안됨):
    <3>CTRL-EVENT-SCAN-STARTED
    <3>CTRL-EVENT-SCAN-RESULTS
    <3>WPS-AP-AVAILABLE
    <3>CTRL-EVENT-SSID-REENABLED id=1 ssid=“idolamba”
    <3>Trying to associate with SSID ‘idolamba’
    <3>Associated with 00:08:9f:b0:39:11
    <3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=KR
    <3>CTRL-EVENT-DISCONNECTED bssid=00:08:9f:b0:39:11 reason=0 locally_generated=1
    <3>CTRL-EVENT-SSID-TEMP-DISABLED id=1 ssid=“idolamba” auth_failures=2 duration=20 reason=CONN_FAILED
    <3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
    <3>CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=GB
    <3>CTRL-EVENT-SCAN-STARTED
    <3>CTRL-EVENT-SCAN-RESULTS
    <3>WPS-AP-AVAILABLE

    테더링 접속시 “<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=KR” 이런 메시지 없이 접속 되더군요.

    핸드폰 테더링으로 접속되는거 보면 RPI3의 wifi 나 드라이버 문제는 아닌거 같습니다. 그런데 접속이 안되는 이유와 해결방법을 찾아보고 있는데 아직 성과가 없네요…
    조언을 기다립니다…^^


  • Global Moderator

    @이돌람바님 현재 저는 IPtime 2004N plus 와 N2E 제품에서 이상없이 사용 중입니다.

    추후 테스트를 위해서 정확한 기기 모델명을 공유 해 주시는 건 어떠 실지요 ?

    참고로 저는 컨트리 국가는 US를 이용 중입니다.



  • @Jae-Sang-Lee 공유기 모델은 N704 입니다. 참고로 이것저것 확인하면서 공유기의 펌웨어도 얼마전에 업데이트했습니다.


  • Global Moderator

    @이돌람바님 제 주변에도 같은 현상을 겪는 분들이 일부 계시는데 US 국가 설정으로 변경 후에 문제가 해결 된 사례도 있었습니다.



  • @Jae-Sang-Lee 저도 RPI3에서 wifi 국가설정을 US,JP로 변경하고 시도하였으나 동일한 증상이었거든요.
    그래서 공유기의 국가 설정도 변경했는데 아무 변화가 없었습니다.
    그래서 의미는 모르겠지만 CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=KR
    이메세지가 키를 쥐고 있지 않을까 생각하고 있거든요…


  • Global Moderator

    @이돌람바님 아래 내용으로 [공지] 로 등록을 해 두었습니다.

    http://forums.rasplay.org/topic/196/공지-raspberrypi-model-3b-wifi-issue



  • iptime공유기 사용하시고 wifi 접속되시는 분들은 wpa_cli 에서 어떻게 보여지는지 궁금하네요…


  • Global Moderator

    @이돌람바님 저는 기본설정을 바꾸지 않고 shell 모드에서 수동설정 모드 보다는 cli 모드를 사용하거나 gui 로 가르치고 있습니다.
    쉬운길을 두고 어렵게 돌아갈 이유가 없기때문 입니다.

    제가 사용하는 어플리케이션은 wicd 입니다.



  • @Jae-Sang-Lee 맞습니다. 아마 저도 접속 이슈가 없었다면 사용하지 않았을 거에요… 문제를 찾으려고 하다보니 접속log를 좀더 자세히 보고 싶었고 결국 wpa_supplicant 프로세스를 보게되었네요…


  • administrators

    네이버 라즈베리파이 카페에도 비슷한 글이 있네요.
    아래 링크를 참고하세요.
    요지는 Iptime 공유기에서 사용하는 미디어텍 칩셋(구 라링크 칩셋)에서 공통적으로 발생하는 문제로
    미디어텍에서 버그가 패치된 칩셋 드라이버를 조만간 배포한다고 하네요.
    참고하세요.

    http://cafe.naver.com/pipc/17503



  • @Jang-Suk-Jung 아… 맞네요… 제가 사용하는 N704 모델도 미디어텍 칩셋 사용하네요… 확인 감사합니다…
    패치 나올때까지 기다려야겠네요…


  • Global Moderator

    @Jang-Suk-Jung 앗 새로운 이슈네여 감사드립다.


답변을 위해 로그인하기